3 Queue [real] Simple, Limit ALL Download

Queue disini benar-benar hanya memakai queue simple (atau simple tingkat lanjut)..
Asumsi jaringan down 1 mbps / up 256 kbps

limit ALL download artinya melimit SEMUA download (yes, from IDM to u'Torrent)
sudah dites dengan ROS 5.23/6.0rc9, dan semoga gak kalah dengan setingan limited download, unlimited browsing yang berbayar.

topologi jaringan:
eth1 = wan / arah ke internet
eth2 = lan / 192.168.0.0/28 --> sesuaikan dengan jaringan agan2
no proxy, no LB.

ip router ke lan : 192.168.0.1

Prasyarat
Spoiler:
selesaikan dahulu setting dasar, router terkoneksi internet, seting gateway di /ip route, seting nat (masquerade), dan dns di /ip dns tes browsing di client, jika sudah bisa maka seting sebagai berikut.

Mangle (letakkan di bawah mangle dynamic, jika ada)
Spoiler:
/ip fi ma
add action=mark-connection chain=forward disabled=no new-connection-mark=all-conn passthrough=yes protocol=icmp
add action=mark-connection chain=forward connection-mark=!heavy-conn disabled=no new-connection-mark=all-conn passthrough=yes src-address=192.168.0.0/28
add action=mark-connection chain=forward connection-bytes=256000-0 connection-mark=all-conn connection-rate=100k-100M disabled=no new-connection-mark=\
heavy-conn passthrough=yes protocol=tcp
add action=mark-connection chain=forward connection-bytes=256000-0 connection-mark=all-conn connection-rate=100k-100M disabled=no new-connection-mark=\
heavy-conn passthrough=yes protocol=udp
add action=mark-packet chain=forward connection-mark=all-conn disabled=no new-packet-mark=all-pack passthrough=no
add action=mark-packet chain=forward connection-mark=heavy-conn disabled=no new-packet-mark=heavy-pack passthrough=no
Queue Type

Spoiler:
/que ty add kind=pcq name=q.type.upload pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \ pcq-dst-address6-mask=64 pcq-limit=20 pcq-rate=128k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=500 add kind=pcq name=q.type.heavy pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \ pcq-dst-address6-mask=64 pcq-limit=20 pcq-rate=512k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=500 add kind=pcq name=q.type.all pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \ pcq-dst-address6-mask=64 pcq-limit=20 pcq-rate=384k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=500
Akhirnya, ini dia queue simple (1 untuk upload, 1 untuk browsing, dan 1 untuk heavy traffic)
Spoiler:
/que sim add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=upload disabled=no interface=ether2 limit-at=0/0 max-limit=256k/512k name=qs.upload parent=\ none priority=8 queue=q.type.upload/default-small target-addresses=192.168.0.0/28 total-queue=default-small add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download disabled=no interface=all limit-at=0/384k max-limit=128k/1M name=qs.all \ packet-marks=all-pack parent=none priority=5 queue=default-small/q.type.all total-queue=default-small add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download disabled=no interface=all limit-at=0/256k max-limit=128k/768k name=qs.heavy \ packet-marks=heavy-pack parent=none priority=7 queue=default-small/q.type.heavy total-queue=default-small
Hasil Torent
Click here to enlarge

Hasil IDM
Click here to enlarge


Keterangan di atas:
1. Untuk download up to 512kbps, jika lebih dari 1 client melakukan aktivitas download maka yang terjadi 768kbps/(banyak client yang download)
2. Untuk browsing up to 384kbps
3. Untuk upload, up to 128kbps, jika lebih dari 1 client yang upload maka yang terjadi 256kbps/ (banyak client yang upload)

0 Response to "3 Queue [real] Simple, Limit ALL Download"

Post a Comment